]> Pileus Git - ~andy/sunrise/blob - dev-util/qdevelop/qdevelop-0.20.ebuild
qdevelop/.: New ebuild for bug #145879
[~andy/sunrise] / dev-util / qdevelop / qdevelop-0.20.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils qt4 toolchain-funcs versionator
6
7 KEYWORDS="~x86"
8
9 MY_P=QDevelop-${PV}
10
11 DESCRIPTION="A development environment entirely dedicated to Qt4."
12 HOMEPAGE="http://qdevelop.org/"
13 SRC_URI="http://qdevelop.org/download/${MY_P}-unstable.zip"
14 LICENSE="GPL-2"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="$(qt4_min_version 4.1)"
19 DEPEND="app-arch/unzip
20                 ${RDEPEND}"
21
22 S=${WORKDIR}/${MY_P}
23
24 pkg_setup() {
25         if ! built_with_use =x11-libs/qt-4* sqlite; then
26                 eerror "x11-libs/qt has to be built with sqlite support"
27                 die "qt sqlite use-flag not set"
28         fi
29 }
30
31 src_compile() {
32         qmake || die "qmake failed"
33         emake CXX=$(tc-getCXX) || die "emake failed"
34 }
35
36 src_install() {
37         dodoc ChangeLog.txt README.txt
38         dobin bin/QDevelop
39 }