]> Pileus Git - ~andy/sunrise/blob - dev-util/monkeystudio/monkeystudio-1.5.2.ebuild
dev-util/monkeystudio: Version bump to v1.5.2
[~andy/sunrise] / dev-util / monkeystudio / monkeystudio-1.5.2.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit qt4
6
7 KEYWORDS="~x86"
8
9 MY_PN="${PN}-src"
10
11 DESCRIPTION="Monkey Studio is a cross platform Qt 4 IDE"
12 HOMEPAGE="http://www.sourceforge.net/projects/monkeystudio"
13 SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}.zip"
14 LICENSE="GPL-2"
15 SLOT="0"
16 IUSE="doc"
17
18 DEPEND="$(qt_min_version 4)"
19 RDEPEND="${DEPEND}"
20
21 S=${WORKDIR}/${MY_PN}-${PV}
22
23 src_unpack() {
24         unpack ${A}
25         sed -i \
26                 -e 's#/build/#build/#g' \
27                 "${S}/monkey.pro" || die "build-dir fix failed"
28 }
29
30 src_compile() {
31         qmake || die "qmake failed"
32         emake || die "emake failed"
33 }
34
35 src_install() {
36         dodoc {Readme,ToDo,WishList,Informations,Changes,Bugs}.txt
37         dobin binary/monkey_x11
38         dosym monkey_x11 /usr/bin/monkeystudio
39         use doc && dohtml -r docqt4ds/english/html/*
40 }