]> Pileus Git - ~andy/sunrise/blob - dev-util/monkeystudio/monkeystudio-1.5.2.ebuild
dev-util/icewing: Fix dependency on x11-libs/gtk+[jpeg] which has been split to x11...
[~andy/sunrise] / dev-util / monkeystudio / monkeystudio-1.5.2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 inherit qt4-r2
7
8 MY_PN="${PN}-src"
9
10 DESCRIPTION="Monkey Studio is a cross platform Qt 4 IDE"
11 HOMEPAGE="http://monkeystudio.sourceforge.net/"
12 SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}.zip"
13
14 KEYWORDS="~x86"
15 LICENSE="GPL-2"
16 SLOT="0"
17 IUSE="doc"
18
19 RDEPEND="x11-libs/qt-gui:4
20         x11-libs/qt-sql:4"
21 DEPEND="${RDEPEND}
22         app-arch/unzip"
23
24 S=${WORKDIR}/${MY_PN}-${PV}
25
26 src_prepare() {
27         sed -i \
28                 -e 's#/build/#build/#g' \
29                 "${S}/monkey.pro" || die "build-dir fix failed"
30 }
31
32 src_install() {
33         dodoc {Readme,ToDo,WishList,Informations,Changes,Bugs}.txt
34         dobin binary/monkey_x11
35         dosym monkey_x11 /usr/bin/monkeystudio
36         use doc && dohtml -r docqt4ds/english/html/*
37 }