]> Pileus Git - ~andy/sunrise/blob - dev-util/mockpp/mockpp-1.14.0.ebuild
Whitespace indentation fixes
[~andy/sunrise] / dev-util / mockpp / mockpp-1.14.0.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 WANT_AUTOCONF="latest"
6 WANT_AUTOMAKE="1.9"
7 inherit eutils autotools
8
9 DESCRIPTION="mockpp is a platform independent generic unit testing framework for C++."
10 HOMEPAGE="http://mockpp.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE="boost cppunit doc"
17
18 RDEPEND="cppunit? ( dev-util/cppunit )
19         boost? ( dev-libs/boost )"
20 DEPEND="${RDEPEND}
21         doc? (  app-doc/doxygen
22                 app-text/docbook-xml-dtd
23                 dev-java/fop )"
24
25 pkg_setup() {
26         if use boost && use cppunit; then
27                 ewarn
28                 ewarn "Both boost and cppunit use-flags specified, will use boost"
29                 ewarn
30         fi
31 }
32
33 src_unpack() {
34         unpack ${A}
35         cd "${S}"
36         epatch "${FILESDIR}/${PV}-destdir.patch"
37         epatch "${FILESDIR}/${PV}-boost_incdir_m4.patch"
38         eautoreconf
39 }
40
41 src_compile() {
42         econf \
43                 $(use_enable cppunit) \
44                 $(use_enable boost boosttest) \
45                 $(use_enable doc doxygen) \
46                 $(use_enable doc docbook) || die "econf failed"
47         emake || die "emake failed"
48 }
49
50 src_install() {
51         # docs get build & installed only if doc use-flag is specified
52         emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" install || die "emake install failed"
53         dodoc ChangeLog AUTHORS README TODO
54 }