]> Pileus Git - ~andy/sunrise/blob - dev-util/lttng-ust/lttng-ust-9999.ebuild
app-misc/qbrew: Fix qt deps, EAPI bump
[~andy/sunrise] / dev-util / lttng-ust / lttng-ust-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit autotools git-2
8
9 DESCRIPTION="Linux Trace Toolkit - UST library"
10 HOMEPAGE="http://lttng.org"
11 EGIT_REPO_URI="git://git.lttng.org/${PN}.git"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE="examples"
17
18 DEPEND="dev-libs/userspace-rcu"
19 RDEPEND="${DEPEND}"
20
21 src_prepare() {
22         if ! use examples; then
23                 sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
24         fi
25         eautoreconf
26 }