]> Pileus Git - ~andy/sunrise/blob - dev-util/lttng-tools/lttng-tools-9999.ebuild
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
[~andy/sunrise] / dev-util / lttng-tools / lttng-tools-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit git-2 linux-info
8
9 DESCRIPTION="Linux Trace Toolkit - next generation"
10 HOMEPAGE="http://lttng.org"
11 EGIT_REPO_URI="git://git.lttng.org/${PN}.git"
12 EGIT_BOOTSTRAP="eautoreconf"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE="+ust"
18
19 DEPEND="dev-libs/userspace-rcu
20         dev-libs/popt
21         ust? ( dev-util/lttng-ust )
22 "
23 RDEPEND="${DEPEND}"
24
25 pkg_pretend() {
26         if kernel_is -lt 2 6 27; then
27                 ewarn "${PN} require Linux kernel >= 2.6.27"
28                 ewarn "   pipe2(), epoll_create1() and SOCK_CLOEXEC are needed to run"
29                 ewarn "   the session daemon. There were introduce in the 2.6.27"
30         fi
31 }
32
33 src_configure() {
34         econf $(use_enable ust lttng-ust)
35 }