]> Pileus Git - ~andy/sunrise/blob - dev-util/lttng-tools/lttng-tools-2.0.4.ebuild
dev-db/cppdb: Adding ~amd64 keyword
[~andy/sunrise] / dev-util / lttng-tools / lttng-tools-2.0.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit linux-info
8
9 DESCRIPTION="Linux Trace Toolkit - next generation"
10 HOMEPAGE="http://lttng.org"
11 SRC_URI="http://lttng.org/files/${PN}/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE="+ust"
17
18 DEPEND="dev-libs/userspace-rcu
19         dev-libs/popt
20         ust? ( dev-util/lttng-ust )
21 "
22 RDEPEND="${DEPEND}"
23
24 pkg_pretend() {
25         if kernel_is -lt 2 6 27; then
26                 ewarn "${PN} require Linux kernel >= 2.6.27"
27                 ewarn "   pipe2(), epoll_create1() and SOCK_CLOEXEC are needed to run"
28                 ewarn "   the session daemon. There were introduce in the 2.6.27"
29         fi
30 }
31
32 src_configure() {
33         econf $(use_enable ust lttng-ust)
34 }