]> Pileus Git - ~andy/sunrise/blob - dev-util/lttng-modules/lttng-modules-9999.ebuild
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
[~andy/sunrise] / dev-util / lttng-modules / lttng-modules-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit git-2 linux-mod
8
9 DESCRIPTION="LTTng Kernel Tracer Modules"
10 HOMEPAGE="http://lttng.org"
11 EGIT_REPO_URI="git://git.lttng.org/${PN}.git"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE=""
17
18 CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
19         ~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"
20
21 pkg_pretend() {
22         if kernel_is lt 2 6 27; then
23                 eerror "${PN} require Linux kernel >= 2.6.27"
24                 die "Please update your kernel!"
25         fi
26 }
27
28 src_compile() {
29         emake default
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" INSTALL_MOD_PATH="${D}" modules_install
34 }