]> Pileus Git - ~andy/sunrise/blob - dev-util/lintian/lintian-2.5.10.3.ebuild
sci-visualization/tulip: Fix qt deps
[~andy/sunrise] / dev-util / lintian / lintian-2.5.10.3.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 #revision for stable versions (e.g. +squeeze1)
8 MY_PVR=""
9
10 inherit eutils
11
12 DESCRIPTION="Debian package checker"
13 HOMEPAGE="http://packages.qa.debian.org/${PN}"
14 SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}${MY_PVR}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 DEPEND=">=dev-lang/perl-5.8.8-r8"
22 RDEPEND="app-arch/dpkg
23         app-misc/hardening-wrapper
24         dev-perl/Archive-Zip
25         dev-perl/Class-Accessor
26         dev-perl/Clone
27         dev-perl/IPC-Run
28         dev-perl/Parse-DebianChangelog
29         dev-perl/Apt-Pkg
30         dev-perl/TimeDate
31         dev-perl/URI
32         dev-util/diffstat
33         dev-util/intltool-debian
34         sys-apps/man-db
35         sys-devel/gettext
36         virtual/perl-Digest-MD5
37         virtual/perl-Digest-SHA
38         ${DEPEND}"
39
40 S="${WORKDIR}/${PN}"
41
42 src_prepare() {
43         # Fixes incorrect reading of exit code for dpkg-vendor
44         epatch "${FILESDIR}"/${P}-FrontendUtil.pm.patch
45         # generate man pages
46         mkdir man/man1 || die
47         private/generate-lintian-pod | pod2man --name lintian \
48                 --center "Debian Package Checker" --section=1 > man/man1/lintian.1 || die
49         pod2man --section=1 man/lintian-info.pod > man/man1/lintian-info.1 || die
50 }
51
52 src_install() {
53         insinto /etc
54         newins doc/${PN}rc.example ${PN}rc
55         dobin frontend/{${PN},${PN}-info}
56
57         local mysharedir=/usr/share/${PN}
58         insinto ${mysharedir}
59         doins -r checks lib profiles vendors
60         doins -r vendors/debian/ftp-master-auto-reject/data
61
62         insinto ${mysharedir}/collection
63         doins collection/*.desc
64         rm collection/*.desc || die
65
66         exeinto ${mysharedir}/collection
67         doexe collection/*
68
69         dodoc doc/{CREDITS,desc-files,${PN}.xml,README.developers}
70         dodoc debian/changelog
71         newdoc doc/README.in README
72         doman man/man1/*
73
74         # Lintian requires a UTF-8 locale in order to properly do man page tests.
75         local mylocaledir=/var/lib/${PN}/locale
76         dodir ${mylocaledir}
77         localedef -i en_US -c -f UTF-8 -A /usr/share/locale/locale.alias \
78                 --quiet "${D}${mylocaledir}"/en_US.UTF-8 || die
79 }