]> Pileus Git - ~andy/sunrise/blob - dev-util/launchtool/launchtool-0.7.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-util / launchtool / launchtool-0.7.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit autotools eutils
8
9 DESCRIPTION="Runs a user-supplied command and can supervise its execution in many ways"
10 HOMEPAGE="http://people.debian.org/~enrico/launchtool.html"
11 SRC_URI="http://people.debian.org/~enrico/woody/source/${PN}_${PV}-1.tar.gz"
12
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 LICENSE="GPL-2"
16 IUSE=""
17
18 RDEPEND="dev-libs/popt"
19 DEPEND="${RDEPEND}"
20
21 src_prepare() {
22         epatch \
23                 "${FILESDIR}"/${PV}-gcc4.4.patch \
24                 "${FILESDIR}"/${PV}-Wall.patch \
25                 "${FILESDIR}"/${PV}-pid.patch
26         eautoreconf
27 }
28
29 src_install() {
30         emake DESTDIR="${D}" install || die
31         dodoc AUTHORS ChangeLog NEWS README TODO || die
32         doman ${PN}.1 || die
33 }