]> Pileus Git - ~andy/sunrise/blob - dev-util/icewing/icewing-0.10.ebuild
Automatic update to use.local.desc
[~andy/sunrise] / dev-util / icewing / icewing-0.10.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit cmake-utils
8
9 DESCRIPTION="Integrated Communication Environment Which Is Not Gesten"
10 HOMEPAGE="http://icewing.sf.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 # need to add xcf, dacs, mvimpact as use-flags (and packages)
17 IUSE="debug ffmpeg +grabber ieee1394 jpeg png readline +unicap"
18
19 DEPEND="
20         sys-libs/zlib
21         x11-libs/gtk+:2
22         x11-libs/gdk-pixbuf[jpeg?]
23         ffmpeg? ( virtual/ffmpeg )
24         ieee1394? ( sys-libs/libraw1394 media-libs/libdc1394:2 )
25         jpeg? ( virtual/jpeg )
26         png? ( media-libs/libpng )
27         readline? ( sys-libs/readline )
28         unicap? ( media-libs/unicap )"
29 RDEPEND="${DEPEND}"
30
31 PATCHES=(
32         "${FILESDIR}"/${P}-gcc64.patch
33         "${FILESDIR}"/${P}-mandir.patch
34         )
35
36 src_configure() {
37         local mycmakeargs="
38                 -DDEBUG:BOOL=$(use debug && echo ON || echo OFF)
39                 $(cmake-utils_use_with ffmpeg FFMPEG)
40                 $(cmake-utils_use_with grabber GRABBER)
41                 $(cmake-utils_use_with ieee1394 FIRE2)
42                 $(cmake-utils_use_with jpeg JPEG)
43                 $(cmake-utils_use_with png PNG)
44                 $(cmake-utils_use_with readline READLINE)
45                 $(cmake-utils_use_with unicap UNICAP)
46                 -DWITH_GTK1=OFF
47                 -DWITH_DACS=OFF
48                 -DWITH_MVIMPACT=OFF
49                 -DWITH_XCF=OFF"
50         einfo "configure arguments: $mycmakeargs"
51         cmake-utils_src_configure
52 }
53
54 pkg_postinst() {
55         elog "Plugins are now compiled into the icewing executable."
56         elog "Issue 'icewing --help' for a list of available plugins."
57 }