]> Pileus Git - ~andy/sunrise/blob - dev-util/icewing/icewing-0.10.ebuild
dev-util/eclipse-epic-bin: Comment out `inherit eclipse-ext', as package is masked...
[~andy/sunrise] / dev-util / icewing / icewing-0.10.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit cmake-utils
8
9 DESCRIPTION="Integrated Communication Environment Which Is Not Gesten"
10 HOMEPAGE="http://icewing.sf.net"
11 SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 # need to add xcf, dacs, mvimpact as use-flags (and packages)
17 IUSE="debug ffmpeg +grabber ieee1394 jpeg png readline +unicap"
18
19 DEPEND="ieee1394? ( sys-libs/libraw1394 media-libs/libdc1394:2 )
20         ffmpeg? ( media-video/ffmpeg )
21         jpeg? ( media-libs/jpeg )
22         png? ( media-libs/libpng )
23         unicap? ( media-libs/unicap )
24         readline? ( sys-libs/readline )
25         sys-libs/zlib
26         x11-libs/gtk+:2[jpeg?]"
27 RDEPEND="${DEPEND}"
28
29 src_configure() {
30         local mycmakeargs="
31                 -DDEBUG:BOOL=$(use debug && echo ON || echo OFF)
32                 $(cmake-utils_use_with ffmpeg FFMPEG)
33                 $(cmake-utils_use_with grabber GRABBER)
34                 $(cmake-utils_use_with ieee1394 FIRE2)
35                 $(cmake-utils_use_with jpeg JPEG)
36                 $(cmake-utils_use_with png PNG)
37                 $(cmake-utils_use_with readline READLINE)
38                 $(cmake-utils_use_with unicap UNICAP)
39                 -DWITH_GTK1=OFF
40                 -DWITH_DACS=OFF
41                 -DWITH_MVIMPACT=OFF
42                 -DWITH_XCF=OFF"
43         einfo "configure arguments: $mycmakeargs"
44         cmake-utils_src_configure
45 }
46
47 pkg_postinst() {
48         elog "Plugins are now compiled into the icewing executable."
49         elog "Issue 'icewing --help' for a list of available plugins."
50 }