]> Pileus Git - ~andy/sunrise/blob - dev-util/gitstats/gitstats-9999.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / dev-util / gitstats / gitstats-9999.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit git
8
9 DESCRIPTION="statistics generator for git"
10 HOMEPAGE="http://gitstats.sourceforge.net/"
11 SRC_URI=""
12 EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
13
14 LICENSE="|| ( GPL-2 GPL-3 )"
15
16 SLOT="0"
17 KEYWORDS=""
18
19 IUSE=""
20 RDEPEND="sci-visualization/gnuplot[gd]
21          dev-util/git"
22
23 src_prepare() {
24         sed "s:basedir = os.path.dirname(os.path.abspath(__file__)):basedir = '/usr/share/gitstats':g" \
25         -i gitstats || die "failed to fix static files path"
26 }
27
28 src_install() {
29         insinto /usr/share/${PN}
30         doins gitstats.css sortable.js *gif || die "failed to install static files"
31         dobin gitstats || die "failed to install ${PN}"
32         dodoc doc/{README,{TODO,author}.txt} || die "doc install failed"
33 }