]> Pileus Git - ~andy/sunrise/blob - dev-util/geany-plugins/geany-plugins-0.18.ebuild
dev-util/geany-plugins: Fix {R,}DEPEND on dev-util/geany to be more general.
[~andy/sunrise] / dev-util / geany-plugins / geany-plugins-0.18.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit base
8
9 DESCRIPTION="A collection of different plugins for Geany"
10 HOMEPAGE="http://plugins.geany.org/geany-plugins"
11 SRC_URI="http://plugins.geany.org/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="enchant gtkspell lua nls"
17
18 RDEPEND="=dev-util/geany-0.18*
19         enchant? ( app-text/enchant )
20         gtkspell? ( app-text/gtkspell )
21         lua? ( dev-lang/lua )"
22 DEPEND="${RDEPEND}
23         nls? ( sys-devel/gettext )"
24
25 src_configure() {
26         econf \
27                 $(use_enable enchant spellcheck) \
28                 $(use_enable gtkspell) \
29                 $(use_enable lua geanylua) \
30                 $(use_enable nls)
31 }