]> Pileus Git - ~andy/sunrise/blob - dev-util/fuzz/fuzz-0.6.ebuild
use /etc/init.d/functions.sh
[~andy/sunrise] / dev-util / fuzz / fuzz-0.6.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="A program to stress-test other programs by giving them random input."
8 HOMEPAGE="http://fuzz.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND=">=sys-libs/readline-4.3"
17 RDEPEND="${DEPEND}"
18
19 src_unpack() {
20         unpack "${A}"
21         cd "${S}"
22         epatch "${FILESDIR}/${P}-gentoo.diff"
23 }
24
25 src_install() {
26         emake DESTDIR="${D}" install || die "emake install failed"
27         dodoc README ChangeLog AUTHORS
28 }