]> Pileus Git - ~andy/sunrise/blob - dev-util/eclipse-epic-bin/eclipse-epic-bin-0.3.0.ebuild
dev-util/eclipse-epic-bin: Initial commit
[~andy/sunrise] / dev-util / eclipse-epic-bin / eclipse-epic-bin-0.3.0.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eclipse-ext
6
7 DESCRIPTION="EPIC is an opensource Perl IDE for the Eclipse platform."
8 HOMEPAGE="http://e-p-i-c.sourceforge.net/"
9 SRC_URI="http://e-p-i-c.sourceforge.net/downloads/org.epic.updatesite_${PV}_20040711.zip"
10 LICENSE="CPL-1"
11 SLOT="0"
12 KEYWORDS="~x86"
13 IUSE=""
14 DEPEND="app-arch/unzip
15         sys-apps/findutils"
16 RDEPEND=">=dev-util/eclipse-sdk-3.0.0
17         dev-lang/perl"
18 S=${WORKDIR}/org.epic.updatesite
19
20 src_unpack() {
21         unpack ${A}
22         cd ${S}
23
24         for jar in `find . -iname *.jar`; do
25         unzip $jar -d ${jar%.jar}
26         rm $jar
27         done
28 }
29
30 src_install() {
31         eclipse-ext_require-slot 3 || die "Failed to find suitable Eclipse installation"
32
33         eclipse-ext_create-ext-layout binary || die "Failed to create layout"
34
35         eclipse-ext_install-features features/* || die "Failed to install features"
36         eclipse-ext_install-plugins plugins/* || die "Failed to install plugins"
37 }