]> Pileus Git - ~andy/sunrise/blob - dev-util/dbdesigner/dbdesigner-4.0.5.4-r1.ebuild
app-backup/rdup: remove obsolete patch from
[~andy/sunrise] / dev-util / dbdesigner / dbdesigner-4.0.5.4-r1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 MY_PN="DBDesigner4"
8
9 DESCRIPTION="QT Database Designer for mysql"
10 HOMEPAGE="http://www.fabforce.net"
11 SRC_URI="http://downloads.mysql.com/${MY_PN}/DBDesigner${PV}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17 RDEPEND="sys-libs/lib-compat
18         x11-libs/kylixlibs3-borqt"
19 DEPEND=""
20
21 S=${WORKDIR}/${MY_PN}
22
23 LL="opt/${MY_PN}/Linuxlib"
24 QA_PRESTRIPPED="${LL}/libdbxoodbc.so
25         ${LL}/libDbxSQLite.so.2.8.5
26         ${LL}/sqlite.so
27         ${LL}/libqt.so.2.3.2
28         ${LL}/bplrtl.so.6.9.0
29         ${LL}/libmidas.so.1.0
30         ${LL}/libqtintf-6.9.0-qt2.3.so
31         opt/${MY_PN}/DBDplugin_SimpleWebFront
32         opt/${MY_PN}/DBDplugin_HTMLReport
33         opt/${MY_PN}/DBDplugin_DataImporter
34         opt/${MY_PN}/${MY_PN}"
35 QA_TEXTRELS="${LL}/libsqlora.so.1.0
36         ${LL}/libmidas.so.1.0
37         ${LL}/libpng.so.2.1.0.12"
38
39 src_install() {
40         local optdir=/opt/${MY_PN}
41
42         insinto "${optdir}"
43         doins -r "${S}"/* || die "doins failed"
44
45         ebegin "Fixing permissions of DBDesigner4 executable"
46         fperms 111 "${optdir}/${MY_PN}"
47         eend
48
49         ebegin "Fixing permissions of startdbd executable"
50         fperms 111 "${optdir}"/startdbd
51         eend
52
53         cd "${D}/${INSTALLDIR}"/Linuxlib
54         einfo "Creating symlinks"
55         ln -sfn "${D}"/opt/kylix3/libborqt-6.9-qt2.3.so libqt.so.2
56         ln -sfn bplrtl.so.6.9.0 bplrtl.so.6.9
57         ln -sfn dbxres.en.1.0 dbxres.en.1
58         ln -sfn libmidas.so.1.0 libmidas.so.1
59         ln -sfn libmysqlclient.so.10.0.0 libmysqlclient.so
60         ln -sfn libqtintf-6.9.0-qt2.3.so libqtintf-6.9-qt2.3.so
61         ln -sfn libsqlmy23.so.1.0 libsqlmy23.so
62         ln -sfn libsqlmy23.so libsqlmy.so
63         ln -sfn libsqlora.so.1.0 libsqlora.so
64         ln -sfn libDbxSQLite.so.2.8.5 libDbxSQLite.so
65         ln -sfn liblcms.so.1.0.9 liblcms.so
66         ln -sfn libpng.so.2.1.0.12 libpng.so.2
67         ln -sfn libstdc++.so.5.0.0 libstdc++.so.5
68         cd "${S}"
69
70         dobin startdbd || die "dobin failed"
71
72         ebegin "Creating Icons"
73         newicon Gfx/Icon48.xpm Icon48.xpm
74         make_desktop_entry startdbd ${MY_PN} Icon48.xpm "Applications;Development"
75         eend
76 }
77
78 pkg_postinst() {
79         einfo
80         einfo "DBDesigner4 is now installed. Use startdbd command to run it"
81         einfo
82 }