]> Pileus Git - ~andy/sunrise/blob - dev-util/colormake/colormake-0.2.ebuild
app-misc/qbrew: Fix qt deps, EAPI bump
[~andy/sunrise] / dev-util / colormake / colormake-0.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4 inherit eutils
5
6 DESCRIPTION="Colorizing wrapper around make"
7 HOMEPAGE="http://bre.klaki.net/programs/colormake/"
8 SRC_URI="${HOMEPAGE}${P}.tar.gz"
9 LICENSE="GPL-2"
10
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="vanilla"
14 RDEPEND="dev-lang/perl"
15
16 S=${WORKDIR}/${PN}
17
18 src_unpack() {
19         unpack ${A}
20         cd "${S}"
21         use vanilla || epatch "${FILESDIR}"/${P}-disable-broken-tagging.patch
22         mv cmake colormake  # prevent clash with dev-util/cmake
23         rm Makefile
24 }
25
26 src_install() {
27         dobin colormake{,.pl} || die
28 }