]> Pileus Git - ~andy/sunrise/blob - dev-tex/sketch/sketch-0.2.90-r1.ebuild
Respect compiler and LDFLAGS, install examples, do not compress PDF docs. Suggested...
[~andy/sunrise] / dev-tex / sketch / sketch-0.2.90-r1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="Produces drawings of two- or three-dimensional solid objects and scenes for TeX"
8 HOMEPAGE="http://www.frontiernet.net/~eugene.ressler/"
9 SRC_URI="http://www.frontiernet.net/~eugene.ressler/${P}.tgz"
10 LICENSE="GPL-3"
11
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE="doc examples"
15
16 DEPEND="dev-lang/perl"
17 RDEPEND=""
18
19 src_unpack() {
20         unpack ${A}
21
22         cd "${S}"
23         sed -i -e "s:\$(CC):\$(CC) \$(LDFLAGS):" makefile
24 }
25
26 src_compile() {
27         emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" || die "emake failed"
28 }
29
30 src_install() {
31         dobin sketch || die
32         edos2unix Doc/sketch.info
33         doinfo Doc/sketch.info || die
34         dohtml updates.htm || die
35         if use doc ; then
36                 insinto /usr/share/doc/${PF}
37                 doins Doc/sketch.pdf || die
38                 dohtml Doc/sketch/* || die
39         fi
40         if use examples ; then
41                 insinto /usr/share/doc/${PF}/examples
42                 doins Data/* || die "Failed to install examples"
43         fi
44 }