]> Pileus Git - ~andy/sunrise/blob - dev-tex/mnsymbol/mnsymbol-1.4.ebuild
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
[~andy/sunrise] / dev-tex / mnsymbol / mnsymbol-1.4.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 inherit latex-package
8
9 DESCRIPTION="Mathematical symbol font for Adobe MinionPro"
10 HOMEPAGE="http://ctan.tug.org/pkg/${PN}"
11 SRC_URI="http://mirror.ctan.org/systems/texlive/tlnet/archive/${PN}.tar.xz -> ${P}.tar.xz
12         source? ( http://mirror.ctan.org/systems/texlive/tlnet/archive/${PN}.source.tar.xz -> ${P}.source.tar.xz )
13         doc? ( http://mirror.ctan.org/systems/texlive/tlnet/archive/${PN}.doc.tar.xz -> ${P}.doc.tar.xz )"
14
15 LICENSE="public-domain"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc source"
19
20 S=${WORKDIR}
21
22 src_install() {
23         # We move all files to the root directory and let the eclass do the magic
24         find "${S}" -mindepth 2 -type f -execdir mv '{}' "${S}" ';' || die
25         latex-package_src_install
26
27         echo "MixedMap ${PN}.map" >> "${T}/${PN}.cfg" || die
28         insinto /etc/texmf/updmap.d
29         doins "${T}/${PN}.cfg"
30 }