]> Pileus Git - ~andy/sunrise/blob - dev-tex/mimetex/mimetex-1.70.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / dev-tex / mimetex / mimetex-1.70.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="mimetex lets you easily embed LaTeX math in your html and dynamic web pages"
8 HOMEPAGE="http://www.forkosh.dreamhost.com/mimetex.html"
9 # forkosh.com only provide mimetex.zip file that is breaking everything when
10 # their is a version bump. I've hosted currente release into my server (volkmar)
11 #SRC_URI="http://www.forkosh.com/${PN}.zip"
12 SRC_URI="http://gentoo.oldworld.fr/distfiles/${P}.zip"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="app-arch/unzip"
20 RDEPEND=""
21
22 S=${WORKDIR}
23
24 src_compile() {
25         $(tc-getCC) ${CFLAGS} -DAA -o ${PN} mimetex.c gifsave.c -lm \
26                 || die "compilation failed"
27 }
28
29 src_install() {
30         dobin ${PN}.cgi || die "installation failed"
31 }