]> Pileus Git - ~andy/sunrise/blob - dev-tex/luximono/luximono-2004.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-tex / luximono / luximono-2004.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit latex-package
6
7 MY_PN="LuxiMono"
8 DESCRIPTION="LaTeX Type1 typewriter font"
9 SRC_URI="http://dev.gentooexperimental.org/~dreeevil/${MY_PN}-${PV}.zip"
10 HOMEPAGE="http://www.ctan.org/tex-archive/fonts/LuxiMono/"
11 LICENSE="luximono"
12
13 IUSE=""
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 RDEPEND="virtual/latex-base"
18 DEPEND="${RDEPEND}
19         app-arch/unzip"
20
21 S=${WORKDIR}/${MY_PN}
22 SUPPLIER="public"
23
24 src_unpack(){
25         unpack ${A}
26         cd "${S}"
27         unzip ul9.zip || die "unzip failed"
28 }
29
30 src_install() {
31         local pack="luxi"
32         local texshr="${TEXMF}/fonts"
33
34         # latex-package_src_doinstall generally uses different
35         # directories than this package expects
36
37         dodoc doc/fonts/luxi/* README.luximono || die "dodoc failed"
38
39         insinto ${texshr}/map/dvips/luxi
40         doins dvips/config/* || die
41
42         insinto ${texshr}/afm/${SUPPLIER}/luxi
43         doins *.afm || die "doins afm failed"
44
45         insinto ${texshr}/tfm/${SUPPLIER}/luxi
46         doins fonts/tfm/public/luxi/*.tfm || die "doins tfm failed"
47
48         insinto ${texshr}/vf/${SUPPLIER}/luxi
49         doins fonts/vf/public/luxi/*.vf || die "doins vf failed"
50
51         insinto ${texshr}/type1/${SUPPLIER}/luxi
52         doins *.pfb || die "doins pfb failed"
53
54         insinto ${TEXMF}/tex/latex/luxi
55         doins tex/latex/luxi/* || die
56
57 }
58
59 pkg_postinst() {
60 #       this order is intended
61         latex-package_rehash
62         updmap-sys --enable Map ul9.map
63 }
64
65 pkg_postrm() {
66         updmap-sys --disable ul9.map
67         latex-package_rehash
68 }