]> Pileus Git - ~andy/sunrise/blob - dev-tex/luximono/luximono-2004.ebuild
748cb4e82213a52e3ee121cac85cfe2793723324
[~andy/sunrise] / dev-tex / luximono / luximono-2004.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit latex-package
6
7 MY_PN="LuxiMono"
8 DESCRIPTION="LuxiMono LaTeX Type1 typewriter font"
9 SRC_URI="http://dev.gentooexperimental.org/~dreeevil/${MY_PN}-${PV}.zip"
10 HOMEPAGE="http://www.ctan.org/tex-archive/fonts/LuxiMono/"
11 LICENSE="luximono"
12
13 IUSE=""
14 SLOT="0"
15 KEYWORDS="~x86"
16
17 DEPEND="app-arch/unzip"
18 RDEPEND=">=app-text/tetex-3.0"
19
20 S=${WORKDIR}/${MY_PN}
21
22 src_unpack(){
23         unpack ${A}
24         cd "${S}"
25         unzip "${S}"/ul9.zip
26 }
27
28 src_install() {
29         local PACK="luxi"
30         local SUPPLIER="public"
31
32 #       latex-package_src_doinstall generally uses different
33 #       directories than this package expects
34 #       cd ${S}
35 #       latex-package_src_doinstall all
36
37         cd "${S}"
38         dodoc doc/fonts/luxi/* README.luximono
39
40         insinto ${TEXMF}/fonts/map/dvips/${PACK}
41         doins dvips/config/*
42
43         insinto ${TEXMF}/fonts/afm/${SUPPLIER}/${PACK}
44         doins *.afm
45
46         insinto ${TEXMF}/fonts/tfm/${SUPPLIER}/${PACK}
47         doins fonts/tfm/public/luxi/*.tfm
48
49         insinto ${TEXMF}/fonts/vf/${SUPPLIER}/${PACK}
50         doins fonts/vf/public/luxi/*.vf
51
52         insinto ${TEXMF}/fonts/type1/${SUPPLIER}/${PACK}
53         doins *.pfb
54
55         insinto ${TEXMF}/tex/latex/${PACK}
56         doins tex/latex/luxi/*
57
58 }
59
60 pkg_postinst() {
61 #       this order is intended
62         latex-package_rehash
63         updmap-sys --enable Map ul9.map
64 }
65
66 pkg_postrm() {
67         updmap-sys --disable ul9.map
68         latex-package_rehash
69 }