]> Pileus Git - ~andy/sunrise/blob - dev-tex/SIstyle/SIstyle-2.3.0.ebuild
sci-visualization/tulip: Fix qt deps
[~andy/sunrise] / dev-tex / SIstyle / SIstyle-2.3.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit latex-package
6
7 DESCRIPTION="LaTeX package to typeset SI units, numbers and angles."
8 HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/SIstyle/"
9 SRC_URI="http://www.rennings.net/gentoo/distfiles/${P}.zip"
10
11 LICENSE="LPPL-1.3b"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND="app-arch/unzip"
17 RDEPEND=""
18
19 S="${WORKDIR}/${PN}"
20
21 src_unpack() {
22         unpack ${A}
23         cd "${S}/source/latex/SIstyle/figs"
24         unpack ./graphs_scr.zip
25 }
26
27 src_install() {
28         cd "${S}/tex/latex/SIstyle"
29         latex-package_src_install
30         cd "${S}/doc/latex/SIstyle"
31         latex-package_src_install
32
33         cd "${S}/source/latex/SIstyle"
34         insinto "${TEXMF}/source/latex/SIstyle"
35         doins sistyle.dtx sistyle.ins figs/fig{1,2}.*ps || die
36         cd figs/graphs_scr
37         insinto "${TEXMF}/source/latex/SIstyle/graphs_src"
38         doins *.mp MPfig.bat readme_figs.txt *.m || die
39 }