]> Pileus Git - ~andy/sunrise/blob - dev-ruby/ruby-gpgme/ruby-gpgme-1.0.4.ebuild
dev-util/qshaderedit: Fix qt deps, EAPI bump
[~andy/sunrise] / dev-ruby / ruby-gpgme / ruby-gpgme-1.0.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit ruby
6
7 DESCRIPTION="Ruby interface to GnuPG Made Easy (GPGME)"
8 HOMEPAGE="http://ruby-gpgme.rubyforge.org/"
9 SRC_URI="http://rubyforge.org/frs/download.php/51466/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE="examples"
15
16 USE_RUBY="ruby18 ruby19"
17 DEPEND=">=dev-lang/ruby-1.8
18         app-crypt/gpgme"
19 RDEPEND="${DEPEND}"
20
21 src_install() {
22         ruby_src_install
23         if use examples; then
24                 docinto examples
25                 dodoc examples/* || die "Failed to install examples"
26         fi
27 }