]> Pileus Git - ~andy/sunrise/blob - dev-ruby/ruby-gd2/ruby-gd2-1.1.1.ebuild
ff87fb7e38ac32a0ea3be2ceec47fea62d734fd2
[~andy/sunrise] / dev-ruby / ruby-gd2 / ruby-gd2-1.1.1.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit ruby gems eutils
6
7 USE_RUBY="ruby18"
8 MY_P="gd2-${PV}"
9
10 DESCRIPTION="Ruby bindings for the GD 2.x graphics library."
11 HOMEPAGE="http://gd2.rubyforge.org/"
12 SRC_URI="http://gems.rubyforge.org/gems/${MY_P}.gem"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND=">=dev-lang/ruby-1.8.4"
20 RDEPEND="${DEPEND}
21         >=media-libs/gd-2.0.0"
22
23 pkg_setup() {
24         if ! built_with_use media-libs/gd truetype ; then
25                 eerror "You need to build media-libs/gd with USE=truetype enabled."
26                 die "gd without truetype-support detected."
27         fi
28 }