]> Pileus Git - ~andy/sunrise/blob - dev-ruby/god/god-0.11.0.ebuild
app-dicts/words-bin: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-ruby / god / god-0.11.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 USE_RUBY="ruby18"
8 RUBY_FAKEGEM_DOCDIR="rdoc"
9
10 inherit ruby-fakegem
11
12 DESCRIPTION="Ruby monitoring framework which replaces monit"
13 HOMEPAGE="http://god.rubyforge.org/"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 # jabber test requires xmpp4r
21 # webhook and campfire tests require json
22 # twitter test requires twitter
23 ruby_add_bdepend "doc? ( dev-ruby/jeweler
24                 virtual/ruby-rdoc )
25         test? ( dev-ruby/jeweler
26                 dev-ruby/json
27                 dev-ruby/mocha
28                 dev-ruby/twitter
29                 dev-ruby/xmpp4r )"
30
31 # After all of our work fixing test dependencies, we can't run them
32 # because they always fail (at least for god-0.11.0).
33 RESTRICT="test"
34
35 all_ruby_prepare() {
36         # the campfire test requires dev-ruby/tinder which would have to
37         # be ebuildized.
38         rm -v test/test_campfire.rb || die
39         # prowly isn't yet an ebuild either
40         rm -v test/test_prowl.rb || die
41 }
42
43 each_ruby_test() {
44         if has userpriv ${FEATURES}; then
45                 ewarn "${PN} requires root priviliges to run its test. Thus, I am not running ${PN}'s"
46                 ewarn "tests. Remove \"userpriv\" from FEATURES to run the tests."
47         else
48                 each_fakegem_test
49         fi
50 }