]> Pileus Git - ~andy/sunrise/blob - dev-ruby/feed2imap/feed2imap-0.9.3.ebuild
dev-ruby/ruby-gpgme: Whitespace
[~andy/sunrise] / dev-ruby / feed2imap / feed2imap-0.9.3.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit ruby
6
7 DESCRIPTION="RSS/Atom feed aggregator which uploads feeds to an IMAP server."
8 HOMEPAGE="http://home.gna.org/feed2imap/"
9 SRC_URI="http://download.gna.org/${PN}/${P}.tgz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
15
16 DEPEND="dev-ruby/ruby-feedparser
17                 dev-ruby/rubymail"
18
19 RDEPEND="${DEPEND}"
20
21 USE_RUBY="ruby18 ruby19"
22
23 src_install() {
24         ${RUBY} setup.rb install --prefix="${D}" "$@" \
25                 ${RUBY_ECONF} || die "setup.rb install failed"
26
27         cd "${S}"
28         dodoc ChangeLog README
29 }
30
31