]> Pileus Git - ~andy/sunrise/blob - dev-python/zanshin/zanshin-0.6.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / dev-python / zanshin / zanshin-0.6.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="2"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 inherit distutils
12
13 DESCRIPTION="High-level library for HTTP, WebDAV and CalDAV operations"
14 HOMEPAGE="http://pypi.python.org/pypi/zanshin/"
15 SRC_URI="mirror://pypi/z/${PN}/${P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~x86"
20 IUSE="doc"
21
22 DEPEND="doc? ( dev-python/epydoc )"
23 RDEPEND="dev-python/twisted-web"
24
25 src_test() {
26         testing() {
27                 PYTHONPATH="build/lib/" $(PYTHON) setup.py test
28         }
29         python_execute_function testing
30 }
31
32 src_compile() {
33         if use doc; then
34                 $(PYTHON -f) setup.py doc || die "Creating the docs failed!"
35         fi
36         distutils_src_compile
37 }
38
39 src_install() {
40         if use doc; then
41                 dohtml -r doc/* || die "Installing the docs failed!"
42         fi
43         distutils_src_install
44 }