]> Pileus Git - ~andy/sunrise/blob - dev-python/spawning/spawning-0.9.7.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / dev-python / spawning / spawning-0.9.7.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 PYTHON_DEPEND="2:2.5"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="2.4 3.*"
9
10 inherit distutils
11
12 MY_PN=Spawning
13 MY_P=${MY_PN}-${PV}
14 DESCRIPTION="A flexible web server written in Python"
15 HOMEPAGE="http://pypi.python.org/pypi/Spawning"
16 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
17
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="~amd64 ~x86"
21 IUSE=""
22
23 DEPEND="dev-python/setuptools"
24 RDEPEND="dev-python/eventlet
25         dev-python/pastedeploy
26         || ( >=dev-lang/python-2.6
27                 ( dev-lang/python:2.5 dev-python/simplejson ) )"
28
29 S=${WORKDIR}/${MY_P}
30
31 src_install() {
32         distutils_src_install
33
34         doinitd rc-scripts/init.d/spawning || die "Install failed"
35         doconfd rc-scripts/conf.d/spawning || die "Install failed"
36 }