]> Pileus Git - ~andy/sunrise/blob - dev-python/spawning/spawning-0.8.12.ebuild
media-radio/ibp: doman needs a 'die'
[~andy/sunrise] / dev-python / spawning / spawning-0.8.12.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils
6
7 MY_PN=Spawning
8 MY_P=${MY_PN}-${PV}
9 DESCRIPTION="A flexible web server written in Python"
10 HOMEPAGE="http://pypi.python.org/pypi/Spawning"
11 SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="dev-python/setuptools"
19 RDEPEND="dev-lang/python
20         dev-python/eventlet
21         dev-python/pastedeploy
22         dev-python/simplejson"
23
24 S=${WORKDIR}/${MY_P}
25
26 src_install() {
27         distutils_src_install
28
29         doinitd rc-scripts/init.d/spawn || die "Install failed"
30         doconfd rc-scripts/conf.d/spawn || die "Install failed"
31 }