]> Pileus Git - ~andy/sunrise/blob - dev-python/repoze-lru/repoze-lru-0.3.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / dev-python / repoze-lru / repoze-lru-0.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 PYTHON_DEPEND="2"
8 SUPPORT_PYTHON_ABIS=1
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 inherit distutils
12
13 MY_PN=${PN/-/.}
14 MY_P=${MY_PN}-${PV}
15
16 DESCRIPTION="A tiny LRU cache implementation and decorator"
17 HOMEPAGE="http://www.repoze.org"
18 SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_P}.tar.gz"
19
20 LICENSE="repoze"
21 SLOT="0"
22 KEYWORDS="~amd64 ~x86"
23 IUSE=""
24
25 S=${WORKDIR}/${MY_P}
26
27 src_test() {
28         testing() {
29                 PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py test
30         }
31         python_execute_function testing
32 }