]> Pileus Git - ~andy/sunrise/blob - dev-python/pyyaml/pyyaml-3.04.ebuild
net-im/pyicq-t: Make this multilib friendly
[~andy/sunrise] / dev-python / pyyaml / pyyaml-3.04.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils
6
7 MY_P=${P/pyyaml/PyYAML}
8
9 DESCRIPTION="PyYAML is a YAML parser and emitter for the Python programming language."
10 HOMEPAGE="http://pyyaml.org/"
11 SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE="examples"
17
18 DEPEND=""
19 RDEPEND="${DEPEND}"
20
21 S=${WORKDIR}/${MY_P}
22
23 src_install() {
24         distutils_src_install
25         if use examples ; then
26                 insinto /usr/share/pyyaml
27                 doins -r examples
28         fi
29 }