]> Pileus Git - ~andy/sunrise/blob - dev-python/pytyrant/pytyrant-1.1.17.ebuild
dev-db/sql2class: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-python / pytyrant / pytyrant-1.1.17.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 PYTHON_DEPEND="2"
7 SUPPORT_PYTHON_ABIS="1"
8
9 inherit distutils eutils
10
11 DESCRIPTION="Python bindings for tokyo tyrant"
12 HOMEPAGE="http://code.google.com/p/pytyrant/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="test"
19
20 DEPEND="test? ( net-misc/tokyotyrant )"
21 RDEPEND=""
22
23 RESTRICT_PYTHON_ABIS="3.*"
24
25 src_prepare() {
26         epatch "${FILESDIR}/return_test_status.patch"
27 }
28
29 src_test() {
30         einfo "${PN} tests require a running instance of tokyo tyrant at port 1978"
31         testing() {
32                 PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" ${PN}.py || die "Tests failed"
33         }
34         python_execute_function testing
35 }