]> Pileus Git - ~andy/sunrise/blob - dev-python/pymox/pymox-0.5.1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / dev-python / pymox / pymox-0.5.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 SUPPORT_PYTHON_ABIS="1"
6
7 inherit distutils
8
9 DESCRIPTION="A mock object framework for Python"
10 HOMEPAGE="http://code.google.com/p/pymox/"
11 SRC_URI="http://${PN}.googlecode.com/files/${P/py}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="virtual/python"
19 RDEPEND="${DEPEND}"
20
21 S=${WORKDIR}/${P/py}
22
23 src_test() {
24         PYTHONPATH=. "${python}" mox_test.py || die "tests failed"
25 }