]> Pileus Git - ~andy/sunrise/blob - dev-python/pylzma/pylzma-0.3.0.ebuild
dev-python/pylzma: Corrected python dependency. Fixed tests.
[~andy/sunrise] / dev-python / pylzma / pylzma-0.3.0.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 NEED_PYTHON=2.4
6
7 inherit distutils
8
9 DESCRIPTION="Python bindings for the LZMA compression library."
10 HOMEPAGE="http://www.joachim-bauch.de/projects/python/pylzma/"
11 SRC_URI="http://www.joachim-bauch.de/projects/python/${PN}/releases/${P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 DEPEND=""
19 RDEPEND=""
20
21 DOCS="doc/usage.txt readme.txt"
22
23 src_test() {
24         einfo "Testing 7zfiles"
25         export PYTHONPATH="$(ls -d build/lib.*)"
26         "${python}" tests/test_7zfiles.py || die "7zfiles test failed"
27         einfo "Testing compatibility"
28         "${python}" tests/test_compatibility.py || die "Compatibility test failed"
29         einfo "Testing pylzma"
30         "${python}" tests/test_pylzma.py || die "pylzma test failed"
31         einfo "Testing usage"
32         "${python}" tests/test_usage.py || die "usage test failed"
33 }