]> Pileus Git - ~andy/sunrise/blob - dev-python/pylibmc/pylibmc-1.1.1.ebuild
dev-python/pylibmc: Define EAPI, adhering to distutils.eclass
[~andy/sunrise] / dev-python / pylibmc / pylibmc-1.1.1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 PYTHON_DEPEND="2:2.5"
7
8 inherit distutils
9 SUPPORT_PYTHON_ABIS="1"
10
11 DESCRIPTION="Libmemcached wrapper written as a Python extension"
12 HOMEPAGE="http://sendapatch.se/projects/pylibmc/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND=">=dev-libs/libmemcached-0.32"
21 DEPEND="${RDEPEND}"
22
23 RESTRICT_PYTHON_ABIS="2.4 3.*"
24
25 src_test() {
26         testing() {
27                 PYTHONPATH="$(dir -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" tests.py || die "Tests failed"
28         }
29         python_execute_function testing
30 }