]> Pileus Git - ~andy/sunrise/blob - dev-python/pygtk-shell/pygtk-shell-0.9.1.ebuild
dev-db/sql2class: Adding ~amd64 keyword
[~andy/sunrise] / dev-python / pygtk-shell / pygtk-shell-0.9.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit distutils
8
9 DESCRIPTION="Framework for interactive GUI programming"
10 HOMEPAGE="http://felixrabe.textdriven.com/pygtk-shell/"
11 SRC_URI="http://felixrabe.textdriven.com/${PN}/releases/${PV}/${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE=""
16 DEPEND=""
17 RDEPEND=">=dev-python/pygtk-2.8
18         dev-python/pycairo"
19
20 src_install() {
21         distutils_src_install
22         make_desktop_entry pygtk_shell.py "PyGTK Shell" " " "System;Shell"
23         echo "OnlyShowIn=GNOME;KDE;XFCE;" >> "${D}"/usr/share/applications/*.desktop
24 }