]> Pileus Git - ~andy/sunrise/blob - dev-python/pygtk-shell/pygtk-shell-0.9.1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update header
[~andy/sunrise] / dev-python / pygtk-shell / pygtk-shell-0.9.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils
6
7 DESCRIPTION="Framework for interactive GUI programming"
8 HOMEPAGE="http://felixrabe.textdriven.com/pygtk-shell/"
9 SRC_URI="http://felixrabe.textdriven.com/${PN}/releases/${PV}/${P}.tar.gz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~x86"
13 IUSE=""
14 DEPEND=""
15 RDEPEND=">=dev-python/pygtk-2.8
16         dev-python/pycairo"
17
18 src_install() {
19         distutils_src_install
20         make_desktop_entry pygtk_shell.py "PyGTK Shell" " " "System;Shell"
21         echo "OnlyShowIn=GNOME;KDE;XFCE;" >> "${D}"/usr/share/applications/*.desktop
22 }