]> Pileus Git - ~andy/sunrise/blob - dev-python/pyexcelerator/pyexcelerator-0.6.4.1.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / dev-python / pyexcelerator / pyexcelerator-0.6.4.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 PYTHON_DEPEND="2"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="3.*"
9
10 inherit distutils
11
12 DESCRIPTION="Python im-/export filters for MS Excel files. Including xls2txt, xls2csv and xls2html commands."
13 HOMEPAGE="http://sourceforge.net/projects/pyexcelerator"
14 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
15
16 LICENSE="BSD-4"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="examples"
20
21 src_install() {
22         distutils_src_install
23
24         dobin tools/xls2csv.py || die
25         dobin tools/xls2html.py || die
26         dobin tools/xls2txt.py || die
27
28         if use examples ; then
29                 insinto /usr/share/doc/${PF}/examples
30                 doins -r examples/* || die
31         fi
32 }