]> Pileus Git - ~andy/sunrise/blob - dev-python/pycallgraph/pycallgraph-0.5.1.ebuild
dev-db/dabo: Adding ~amd64 keyword, fixing deps, fixing distutils usage
[~andy/sunrise] / dev-python / pycallgraph / pycallgraph-0.5.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 SUPPORT_PYTHON_ABIS="1"
7
8 inherit distutils
9
10 DESCRIPTION="Python library that creates call graphs for Python programs"
11 HOMEPAGE="http://pycallgraph.slowchop.com/"
12 SRC_URI="http://${PN}.slowchop.com/files/download/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="examples"
18
19 RDEPEND="media-gfx/graphviz"
20
21 RESTRICT_PYTHON_ABIS="3*"
22
23 src_install() {
24         distutils_src_install
25
26         if use examples; then
27                 insinto /usr/share/doc/${PF}/examples
28                 doins -r examples/* || die "Install failed"
29         fi
30 }