]> Pileus Git - ~andy/sunrise/blob - dev-python/pyRXP/pyRXP-9999.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / dev-python / pyRXP / pyRXP-9999.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit distutils subversion
8
9 DESCRIPTION="Binding to RXP, a very fast validating XML parser."
10 HOMEPAGE="http://www.reportlab.org/pyrxp.html"
11 ESVN_REPO_URI="http://svn.reportlab.com/svn/public/${PN}/trunk/src"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE="doc examples"
17
18 DOCS="README"
19
20 src_install() {
21         if use doc;then
22            DOCS="${DOCS} docs/*"
23         fi
24
25         distutils_src_install
26
27         if use examples;then
28            docinto examples
29            dodoc examples/* || die "dodoc examples code failed"
30         fi
31 }