]> Pileus Git - ~andy/sunrise/blob - dev-python/pottymouth/pottymouth-2.1.2.ebuild
dev-python/pottymouth: Fix path to patch
[~andy/sunrise] / dev-python / pottymouth / pottymouth-2.1.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 PYTHON_DEPEND="2"
7 SUPPORT_PYTHON_ABIS="1"
8
9 inherit distutils eutils
10
11 MY_P=PottyMouth-${PV}
12 DESCRIPTION="A python library that scrubs untrusted text to valid, nice-looking, completely safe XHTML"
13 HOMEPAGE="http://glyphobet.net/pottymouth/"
14 SRC_URI="${HOMEPAGE}dist/${MY_P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RESTRICT_PYTHON_ABIS="3.*"
22
23 S=${WORKDIR}/${MY_P}
24
25 DOCS="readme.html"
26
27 src_prepare() {
28         epatch "${FILESDIR}/${P}-fix-setup.patch" || die
29 }
30
31 src_test() {
32         testing() {
33                 PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test.py || die "Tests failed"
34         }
35         python_execute_function testing
36
37 }