]> Pileus Git - ~andy/sunrise/blob - dev-python/pottymouth/pottymouth-1.2.2.ebuild
dev-python/pottymouth: Reintroduce PYTHON_DEPEND
[~andy/sunrise] / dev-python / pottymouth / pottymouth-1.2.2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 PYTHON_DEPEND="2"
7 SUPPORT_PYTHON_ABIS="1"
8
9 inherit distutils
10
11 MY_P=PottyMouth-${PV}
12 DESCRIPTION="A python library that scrubs untrusted text to valid, nice-looking, completely safe XHTML"
13 HOMEPAGE="http://glyphobet.net/pottymouth/"
14 SRC_URI="${HOMEPAGE}dist/${MY_P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RESTRICT_PYTHON_ABIS="3.*"
22
23 S=${WORKDIR}/${MY_P}
24
25 src_prepare() {
26         sed -i -e "s/python-pottymouth/${PF}/g" setup.py || die "sed failed"
27 }
28
29 src_test() {
30         testing() {
31                 PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test.py || die "Tests failed"
32         }
33         python_execute_function testing
34
35 }