]> Pileus Git - ~andy/sunrise/blob - dev-python/pottymouth/pottymouth-1.2.0.ebuild
Automatic update to use.local.desc
[~andy/sunrise] / dev-python / pottymouth / pottymouth-1.2.0.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 NEED_PYTHON=2.4
6 SUPPORT_PYTHON_ABIS=1
7
8 inherit distutils
9
10 MY_P=PottyMouth-${PV}
11 DESCRIPTION="A python library that scrubs untrusted text to valid, nice-looking, completely safe XHTML"
12 HOMEPAGE="http://devsuki.com/pottymouth/"
13 SRC_URI="${HOMEPAGE}/dist/${MY_P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 DEPEND="dev-python/setuptools"
21 RDEPEND=""
22
23 RESTRICT_PYTHON_ABIS="3*"
24 S=${WORKDIR}/${MY_P}
25
26 src_test() {
27         ${python} test.py || die "Tests failed"
28 }