]> Pileus Git - ~andy/sunrise/blob - dev-python/pottymouth/pottymouth-1.1.4.ebuild
ced762b13fdd9379d7bccd45cd32e897b53a7456
[~andy/sunrise] / dev-python / pottymouth / pottymouth-1.1.4.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils
6
7 MY_PN="PottyMouth"
8 MY_P=${MY_PN}-${PV}
9 DESCRIPTION="A python library that scrubs untrusted text to valid, nice-looking, completely safe XHTML"
10 HOMEPAGE="http://devsuki.com/pottymouth/"
11 SRC_URI="http://devsuki.com/${PN}/dist/${MY_P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="dev-python/setuptools"
19 RDEPEND="dev-lang/python"
20
21 S=${WORKDIR}/${MY_P}
22
23 src_test() {
24         distutils_python_version
25         ${python} setup.py test || die "Tests failed"
26 }