]> Pileus Git - ~andy/sunrise/blob - dev-python/path/path-2.2.2.ebuild
app-office/radicale: Adding ~amd64 keyword
[~andy/sunrise] / dev-python / path / path-2.2.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 PYTHON_DEPEND="2:2.5 3:3.1"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="2.4"
9 PYTHON_TESTS_RESTRICTED_ABIS="3.*"
10
11 MY_PN=${PN}.py
12
13 inherit distutils
14
15 DESCRIPTION="Helpful python wrapper to the os.path module"
16 HOMEPAGE="http://pypi.python.org/pypi/path.py"
17 SRC_URI="mirror://pypi/p/${MY_PN}/${MY_PN}-${PV}.tar.gz"
18
19 LICENSE="MIT"
20 SLOT="0"
21 KEYWORDS="~amd64 ~x86"
22 IUSE=""
23
24 S="${WORKDIR}/${MY_PN}-${PV}"
25
26 src_prepare() {
27         # Don't install test_path.py
28         sed -i \
29                 -e "s/, 'test_path'//" \
30                 setup.py || die "sed failed"
31 }
32
33 src_test() {
34         my_test() {
35                 "$(PYTHON)" test_path.py
36         }
37         python_execute_function my_test
38 }