]> Pileus Git - ~andy/sunrise/blob - dev-python/openopt/openopt-0.29.ebuild
dev-libs/libserial: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-python / openopt / openopt-0.29.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 PYTHON_DEPEND="2:2.5"
7 SUPPORT_PYTHON_ABIS="1"
8 PYTHON_MODNAME="openopt"
9
10 inherit distutils
11
12 MY_PN="OpenOpt"
13
14 DESCRIPTION="A python module for numerical optimization"
15 HOMEPAGE="http://openopt.org"
16 SRC_URI="http://openopt.org/images/3/33/${MY_PN}.zip"
17
18 LICENSE="BSD"
19 SLOT="0"
20 KEYWORDS="~amd64 ~x86"
21 IUSE="examples"
22
23 RDEPEND="dev-python/numpy"
24 DEPEND="${RDEPEND}
25         dev-python/setuptools"
26 RESTRICT_PYTHON_ABIS="2.4 3.*"
27
28 S=${WORKDIR}/${MY_PN}
29
30 src_prepare() {
31         sed -i -e 's/find_packages()/find_packages(exclude=["openopt.examples", "openopt.tests"])/' setup.py || die
32 }
33
34 src_install() {
35         distutils_src_install
36
37         if use examples; then
38                 insinto /usr/share/${PF}/examples
39                 doins -r openopt/examples/* || die
40         fi
41 }