]> Pileus Git - ~andy/sunrise/blob - dev-python/ncrypt/ncrypt-0.6.4.ebuild
dev-db/dabo: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-python / ncrypt / ncrypt-0.6.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 PYTHON_DEPEND="2"
8 SUPPORT_PYTHON_ABIS="1"
9
10 inherit distutils eutils python
11
12 DESCRIPTION="A python wrapper for OpenSSL"
13 HOMEPAGE="http://tachyon.in/ncrypt/"
14 SRC_URI="http://fs.tachyon.in.s3.amazonaws.com/${PN}/${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE=""
20
21 DEPEND="dev-libs/openssl
22         dev-python/pyrex"
23 RDEPEND="${DEPEND}"
24
25 RESTRICT_PYTHON_ABIS="3.*"
26
27 DOCS="website/usage.txt"
28
29 src_prepare() {
30         epatch "${FILESDIR}/cinit.patch"
31 }