]> Pileus Git - ~andy/sunrise/blob - dev-python/mother/mother-0.6.4-r5.ebuild
dev-libs/liblouis: Adding ~amd64 keyword
[~andy/sunrise] / dev-python / mother / mother-0.6.4-r5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 PYTHON_DEPEND="2"
7 SUPPORT_PYTHON_ABIS="1"
8
9 inherit distutils
10
11 DESCRIPTION="An Object Relational Mapper with strong introspection"
12 HOMEPAGE="http://www.dbmother.org/"
13 SRC_URI="http://www.dbmother.org/download/${PF}.tgz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc examples +postgres sqlite"
19
20 RDEPEND="
21         sqlite? ( dev-python/apsw )
22         postgres? ( >=dev-python/psycopg-2.0 )"
23 DEPEND="${RDEPEND}"
24 RESTRICT_PYTHON_ABIS="3.*"
25
26 S=${WORKDIR}/${PF}
27
28 src_install() {
29         distutils_src_install
30
31         doman doc/mothermapper.1 || die
32
33         if use examples; then
34                 insinto /usr/share/doc/${PF}/examples
35                 doins examples/* || die
36         fi
37
38         if use doc; then
39                 dodoc doc/manual.* || die
40         fi
41 }